Windows远程报错 : 要求的函数不受支持、这可能是由于 CredSSP 加密 Oracle 修正
发布于 2018-05-28    252 次阅读
使用Windows远程报错,提示:要求的函数不受支持,这可能是由于 CredSSP 加密 Oracle 修正。可通过将远程桌面属性修改为“允许运行任意版本远程桌面的计算机连接”,应用后,连接成功。这种方式比较便捷,但是不太安全,不建议在服务器上使用。

问题描述

使用 Window10 专业版,远程链接另外一台 Window10 专业版时,报错“要求的函数不受支持,这可能是由于 CredSSP 加密 Oracle 修正”

如下图所示:

Windows远程报错 : 要求的函数不受支持、这可能是由于 CredSSP 加密 Oracle 修正

 

问题原因

凭据安全服务提供者(CredSSP,Credential Security Service Provider)是安全服务提供者,用于将用户凭据委派到应用程序中,以实现从客户端到目标服务器的认证。

CredSSP 的未修补版本中存在远程代码执行漏洞。 成功利用此漏洞的攻击者可以在目标系统上中继用户凭据以执行代码。任何依赖 CredSSP 进行身份验证的应用程序都可能容易受到此类攻击。

2018年5月8日,微软在补丁中修改了策略,在某些情况会出现远程连接报错。

 

解决方案

将远程桌面属性修改为“允许运行任意版本远程桌面的计算机连接”

修改路径为:计算机 -> (右键) 属性 -> 远程设置,如图所示:

voidcc.com开发小院备注 :这种方式比较方便,但是不太安全,服务器环境不推荐使用。

 

其余解决方案

1、通过gpedit.msc打开本地组策略管理器,依次展开 计算机配置 -> 管理模板 -> 系统 -> 凭据分配 -> 设置名称:加密Oracle修正,然后右键编辑,改为启用,级别为易受攻击。

2、对于Win 10家庭版,没有组策略管理器,此时需要修改注册表,HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters,新建DWORD 类型的 AllowEncryptionOracle,值为2,重启系统。

版权说明 : 本文为 开发小院 原创文章, 转载时请注明作者和原文连接

文章标题 : Windows远程报错 : 要求的函数不受支持、这可能是由于 CredSSP 加密 Oracle 修正

文章连接 : http://www.voidcc.com/content/windows-remote-error-credssp-oracle


 主题目录

    欢迎关注本站公众号 开发小院